View Full Version : [FIXED] Project Upgrade to 2.1

16 Aug 2012, 11:40 PM

I've upgraded to 2.1 and tried to open my project; I get the message that the project was generated with an older version and needs to be upgraded. So, go ahead with the Upgrade, Architect starts to load my project, and get the message, "This project is being upgraded". It never completes; I've left it all day and it was in the same state.


This project is in a Kiln repo ... so just in case I tried the upgrade from the desktop. I thought I might be getting somewhere, as I get an error message first.


But no, same problem, stuck at the project upgrade process.


17 Aug 2012, 8:08 AM
We've fixed this bug and it will be going out it in a patch release.

20 Aug 2012, 4:00 AM
That's great, any idea when? I have a project I need to update. If more than a day or so, I'll need to revert back to the previous Architect version (if that is possible?)

21 Aug 2012, 4:11 AM
Very annoyed and upset. I've just lost a very long morning's work.

I've had to revert to 2.0 as I needed to update a project. Despite the fact that for some reason, various settings and all my custom JS was missing, I could fudge my way around and get it to work. Deploy wasn't working, forcing me to manually copy files and folders. It's a workaround I could live with whilst I wait for 2.1 to be fixed.

Just gone to save the project and Architect crashes. Happens several times a day, but I save every couple of minutes, so shouldn't have lost much work. Open the project and all my views are gone (again!). This means going back to source control, which means all work and updates today are lost.

Unbelievable, so annoyed :(

21 Aug 2012, 7:17 AM
I'm sympathetic towards you and the lost work. In what build did Architect crash? Could you give us steps to reproduce and/or the project (in private at architect.feedback at sencha.com)?

The original referenced bug is fixed in 2.1 build 588. This release went out yesterday.

21 Aug 2012, 8:02 AM
Thanks Aaron.

Version 2.0.0 .... Build: undefined (!)
Release Channel: 2.0-stable

If I allow Architect to update ("A new major update is available on the website. Would you ....."), would that be build 588, which would allow me to upgrade the project to work in 2.1?

If so, that would be the solution.

21 Aug 2012, 8:48 AM
Build undefined? Not sure, how you were able to get into that state. :-/

Yes, if you allow Architect to update you will download the new major version (2.1.0 build 584). Immediately after launching it you should get a minor update to (2.1.0 build 588).

21 Aug 2012, 9:04 AM
Uninstalled 2.1, reinstalled 2.0:38127

Thanks, I'll try the update again shortly.

21 Aug 2012, 9:29 AM
OK, downloaded 2.1 again, installed it, verified it's build 584, but it will not update to 588.

However.... I then allowed Architect to upgrade the project (which never completed before) and this time it converted successfully. It's still at build 584, so quite a strange one. Would you still like the project or does it not matter now?


(although memory usage is currently at 468,592k and rising....)

22 Aug 2012, 12:30 AM
Just to put a closure to this; I've left the app running overnight with my project open, and memory has reduced to 345MB.

Thanks, all sorted now :)

22 Aug 2012, 6:46 AM
Just to be sure I can run your project through some tests to be sure nothing out of the ordinary is occuring. might help us find a bug.

Architect (dot) feedback -(at)- sencha.com

an XDA would be best or a zip

23 Aug 2012, 10:00 AM
Just PM'd you Phil...

24 Aug 2012, 7:33 AM
I got your project looking over it now.

24 Aug 2012, 11:39 AM
Ok so your project helped us find 2 bugs. Because you had a grid inside of a collapsed panel that fired an onRender event but was in fact never rendered (if shouldn't have been).

We've added some extra checks to Architect so this won't happen after the next patch. Know that your project is completely safe though Architect will be annoying until the patch is released.