PDA

View Full Version : Issues for ExtJS 3.x.x and 4.x.x to support IE10



Tony_Peng
21 Aug 2012, 1:32 AM
Hi, Sencha:

I purchased ExtJS 3.x.x to develop my web app for a period. Due to Windows 8 - IE10, I test my app to know the condition. Problems as below:

The latest version of ExtJS 3 series is 3.4.x. This series will continue upgrade? or this indicates necessary to upgrade from 3.x.x to 4.x.x?
Any schedules to support IE10 in ExtJS 3.x.x and ExtJS 4.x.x?

scottmartin
21 Aug 2012, 11:25 AM
The license covers all versions as well as a term for support.

We will provide support for new versions of IE upon release.
Tweaks may have to be performed on each version once this happens.

Scott.

Tony_Peng
21 Aug 2012, 7:11 PM
Hi, scottmartin.

Thanks for replying.

First I want to know is that ExtJS 3.x.x will be on developing?
I mean that Ext JS 3.4.x, 3.5.x, 3.6.x....can be released in future.
Sencha team has any schedule for this?

If not, upgrade from 3 to 4 is necessary?

scottmartin
25 Aug 2012, 9:17 PM
This is certainly possible, but they will be maintenance releases AFAIK
3.4.1 was recently released to support subscribers.

This is up to the development team based on user needs. There is no way to forecast this.

New development will concentrate on the latest version.

Scott.