PDA

View Full Version : Android package run problems



sencha2cool
22 Aug 2012, 11:07 AM
Hello,
Created simple "toy" app works in browser.
When type sencha package run filename.json the MyApplication.apk gets built, but does not run on device -- after download get Parse error There is a problem parsing the package.
At end of build get [ERROR] multiple devices and emulators

Please advise.

sencha2cool
22 Aug 2012, 11:26 AM
Finally got "toy" app to run on Android device (sort of) !

At end of build, get BUILD SUCCESSFUL ... Success ... Starting: Intent ... shel am start -n .../.STActivity [ERROR] 2175 KB/s (36191180 bytes in 16.243s)

Also, Lists are not displaying content from stores -- works on browser.

Please Advise.

sencha2cool
22 Aug 2012, 12:05 PM
Lists do appear on Android if basic lists with or without disclosures.
Lists do not appear on Android if Grouped list -- then only see one blank list item which does respond properly when tapped.

I think this is a bug !

sencha2cool
22 Aug 2012, 12:42 PM
I spoke too soon, sometimes lists appear correctly in Android and sometimes just one blank list item which when tapped responds correctly.

Please advise.

sencha2cool
22 Aug 2012, 12:54 PM
Looking at forums this may be due to having a HTC Android version 2.3.3 device -- agree ?

sencha2cool
22 Aug 2012, 1:04 PM
What Android Devices (phone and tablet) would you recommend to start developing mobile apps without even more problems ?

sencha2cool
22 Aug 2012, 1:27 PM
Just built "toy" app on a HTC tablet running Android version 2.3.4 -- but just getting white screen.
Able to build (sort of) on a HTC phone running Android version 2.3.3.

Please advise.

sencha2cool
22 Aug 2012, 2:00 PM
Just updated HTC Tablet to Android version 3.2.1 and re-ran sencha package run filename.json
Still just seeing white screen -- works fine on Chrome browser on PC geberated from Architect

At least most of app appears when building on HTC EVO phone (Android version 2.3.3) -- but problems with entire List Items not displaying on some screens -- Why??

Very Frustrating !

sencha2cool
24 Aug 2012, 7:48 AM
Lists display issue on HTC EVO phone resolved !
To get Lists to display needed to have ArrayStore autoload turned off (unchecked) which is surprising to me.

sencha2cool
24 Aug 2012, 9:21 AM
Still just seeing White Screen on HTC EVO View Tablet -- even after fixing all console warnings when in Debug mode in Browser before rebuild.

Please advise.

sencha2cool
24 Aug 2012, 10:52 AM
Recap: When execute sencha package run filename.json eventually get: (but does load on HTC View and run on HTC phone)
BUILD SUCCESSFUL
Total time: 22 seconds
pkg: /data/local/tmp/MyApplication6.apk

Success

Starting: Intent { cmp=com.mycompany.myAppID/.STActivity }

""c://Program Files//Android//android-sdk\tools\android" create project --target android-14 --name MyApplication6 --activity STActivity --path "../build/\/" --package com.mycompany.myAppID"
""c://Program Files//Android//android-sdk\platform-tools\adb" install -r "../build/\MyApplication6.apk""
""c://Program Files//Android//android-sdk\platform-tools\adb" shell am start -n com.mycompany.myAppID/.STActivity"
[ERROR] 3308 KB/s (36191270 bytes in 10.682s)

sencha2cool
24 Aug 2012, 12:27 PM
Update: modified CSS file to add:
body {background: green;}

When re-build on HTC tablet do see green screen -- so something else is wrong.
How to fix ?

sencha2cool
24 Aug 2012, 12:48 PM
Update: Using logcat see:
couldn't save which view has focus because the focused view [email protected] has no id.
call to OpenGL ES API with no current context

sencha2cool
27 Aug 2012, 11:16 AM
Tried sencha app build native -- mostly works on HTC EVO View, but when play video only hear audio and also not seeing posterURL image.