PDA

View Full Version : upgrade my project from a 4.0.7 one to a 4.1.1 one in Architect



ahsec
27 Aug 2012, 12:46 AM
Hello

I've so far done it through changing the sources in the app.html file to the ones the deployment dumps to file when using a new 4.1.1 based sencha project.

i.e
to
<script type="text/javascript" src="http://extjs.cachefly.net/ext-4.1.1-gpl/ext-all.js"></script>

I haven't seen any way to do it through the Architect's settings...

Any ideas anyone?

Thanks

aconran
27 Aug 2012, 8:18 AM
To get the new functionality inside of the Ext 4.1.x library, right click on the Library and click Upgrade to Ext JS 4.1.x.

You can then point the library's base url to a place where the 4.1.1 library is.

Note that this will make all changes necessary *EXCEPT* upgrading your overrides. Ext 4.1.x has a preferred format over Ext 4.0.x, you will have to change these manually.

From this style


Ext.define('MyApp.view.override.MyWindow', {
requires: 'MyApp.view.MyWindow'
}, function() {
Ext.override(MyApp.view.MyWindow, {

});
});


To this style


Ext.define('MyApp.view.override.MyWindow', {
override: 'MyApp.view.MyWindow'

});