PDA

View Full Version : Why doesn't this photo upload plugin work in IE?



blex2010
31 Aug 2012, 12:25 PM
Hi,

I'm trying to use this photo upload plugin in IE and it fails in IE8 and 9. It works fine in Chrom,FF,Safari but we have a lot of IE users.

http://www.developerextensions.com/index.php/extjs-photo-uploader

Any ideas?

Thanks!

Scott

scottmartin
1 Sep 2012, 9:38 AM
Does the file upload component we provide work as expected? I understand you want features of this control, but you need to narrow down the problem first.

Do you see any errors in the console?

Since this is a 3rd party control, have you tried to contact the author?

Scott.

blex2010
10 Sep 2012, 7:56 AM
When we try to use extjs upload in our code it is also failing but not the same error (in extjs code though) so not sure if it is the same problem. Again, works fine in every browser except IE. We read something about IE not liking the div being dynamically created for the upload form but haven't found a solution.

The page we are adding this to is a pretty sophisticated framework so it is hard to break it out. I assume a simple example of the uploader works or you would know about it. We did confirm that the widget we are trying to use does not work in IE 8/9 so it is in their code, not ours.

We contacted the developer and he said he doesn't work on IE so he didn't catch it. He'll look at it eventually but I'm stuck right now and don't know how to isolate the issue.

scottmartin
10 Sep 2012, 8:19 AM
We read something about IE not liking the div being dynamically created for the upload form

Do you possible the have thread/report for this? I did not see anything in our tracker.

You may have to create a bug report for this if you are having related issues. Can this be duplicated on our examples?

The issue is we need to isolate the problem to the fileupload and determine if this is the cause or something in your code that may be a cause. Sometimes a test case can help you find the problem in your own code, as you are able to add code/css until the problem occurs, where it does not in a base example.

Scott.

blex2010
10 Sep 2012, 8:24 AM
So now we are talking about two problems:
1. The widget I am trying to use is failing and that widget fails outside of our code (standalone).
2. The ExtJS upload work in a standalone example (in ie) but not in our code. So I don't think the problem is with the ExtJS but our code is too large to build a simple test case. I can report a bug as best I can but since my original post was about the widget above and I can't reproduce the problem with the ExtJS outside my code not sure if it is helpful.

I guess I'm saying problem #1 is my concern and doesn't look like it is the same problem as #2 however it is helpful for you and the community I'll post a bug on what we are seeing just in case as I haven't found any posts on the issue.