PDA

View Full Version : Problems with animateX not being defined



Animal
21 Feb 2007, 3:12 AM
I have included the files like this:



<script type="text/javascript" src="/aspicio/js/yui-utilities.js" ></script>
<script type="text/javascript" src="/aspicio/js/logger.js" ></script>
<script type="text/javascript" src="/aspicio/js/treeview.js" ></script>
<script type="text/javascript" src="/aspicio/js/container.js" ></script>
<script type="text/javascript" src="/aspicio/js/calendar.js" ></script>
<script type="text/javascript" src="/aspicio/js/menu.js" ></script>
<script type="text/javascript" src="/aspicio/js/ext-all.js" ></script>
<script type="text/javascript" src="/aspicio/js/ext-bridge-yui.js" ></script>


Followed by all our own scripts.

But on expand/collapse of a Region, it's trying to create a YAHOO.util.Anim, and call animateX on it.

This looks like it is being set up by ext-bridge-yui.js, but that doesn't seem to work!

Firebug tells me all the scripts are in the correct place - no 404s!

What am I doing wrong :?: http://www.timetriallingforum.co.uk/style_emoticons/default/uhm.gif

Sliver
21 Feb 2007, 5:06 AM
There is a real problem with animateX.

Just go on the documentation page (make sure Firebug is running) :
http://www.jackslocum.com/deploy/ext-1.0-alpha1/docs/

and try to minimize the left documention explorer.... you will have the error message :

59.animateX is not a function
slideIn(Object width=Object, Object scope=Object block=true anim=Motion yui-gen53, function(), 0.5, function(), function())ext-all.js (line 24)
slideIn()ext-all.js (line 24)
slideIn()ext-all.js (line 24)
slideIn(Object scope=Object block=true anim=Motion yui-gen53, function())ext-all.js (line 24)
slideIn("l", Object scope=Object block=true anim=Motion yui-gen53)ext-all.js (line 24)
SplitLayoutRegion()ext-all.js (line 188)
LayoutRegion(Object browserEvent=Event mouseout button=0 shiftKey=false)ext-all.js (line 186)
EventManager(Object browserEvent=Event mouseout button=0 shiftKey=false)ext-all.js (line 18)
namespace(click clientX=0, clientY=0)utilities_2.1.0.j... (line 2)
[Break on this error] Ext.enableFx=true;Ext.apply(Ext.Element.prototype,{slideIn:function(_1,o){var el...

Animal
21 Feb 2007, 5:26 AM
Well, that's sort of good. At least I'm not doing something blindingly stupid! I should think this will be patched quickly.

jack.slocum
21 Feb 2007, 9:13 AM
animateX is in the ext-bridge-yui.js. The error in the docs is because they aren't including ext-bridge-yui.js. :) Are you sure everything is right?

Wolfgang
21 Feb 2007, 11:29 AM
I think this matches what i have written here:
http://www.yui-ext.com/forum/viewtopic.php?t=2832

Still did not had the time to check wether the yui debug versions are the root cause.

Animal
22 Feb 2007, 2:55 AM
It's still definitely not defined for me, and my document head looks like this:



<script type="text/javascript" src="/aspicio/js/yui-utilities.js" ></script>
<script type="text/javascript" src="/aspicio/js/logger.js" ></script>
<script type="text/javascript" src="/aspicio/js/treeview.js" ></script>
<script type="text/javascript" src="/aspicio/js/container.js" ></script>
<script type="text/javascript" src="/aspicio/js/calendar.js" ></script>
<script type="text/javascript" src="/aspicio/js/menu.js" ></script>
<script type="text/javascript" src="/aspicio/js/ext-all.js" ></script>
<script type="text/javascript" src="/aspicio/js/ext-bridge-yui.js" ></script>


And I can see ext-bridge-yui.js in Firebug's script tab. It's just not being executed!

I've uncompressed it. I can set a breakpoint on the first line



(function(){
9 var E=YAHOO.util.Event;
10 var D=YAHOO.util.Dom;
11 var ES=YAHOO.util.Easing;
12 var A=YAHOO.util.Anim;
13 Ext.apply(Ext.compat, {
14 get:function(el) {
15 return D.get(el);
16 }
17 });
18})();
19


But it does not get into the other lines at all....

Firefox 2.0.0.1

Animal
22 Feb 2007, 3:13 AM
Forget about it! All my own bad work! And the other probs that I reported! :oops: