View Full Version : Problems installing Sencha SDK tools

30 Sep 2012, 11:28 PM
Hi there,

I start the installation of the SDK tools, pretty straight forward, click next, next, Accept, install, etc...

And then it doesn't do anything! It just says "Preparing to install", and it keeps it there until the end of the world, just doing nothing... I have check the Windows' logs and it doesn't say anything about errors or anything, what can be the cause?

Screenshot of the 'dead' point.


Any help would be very appreciated.

I am using Windows 7 x64

1 Oct 2012, 12:05 AM
For some reason the executable I had was not working, I tried with another one provided by a colleague and it installed. Weird thing: we both downloaded it from the official Sencha site. My version has date 31-08-2012 his version is 01-07-2012...

1 Oct 2012, 12:55 PM
Just double-checking that you are intended to use SDK Tools V2 (for Sencha Touch 2.0)...

You will need Sencha Cmd V3 (name change) found below for Sencha Touch 2.1.


1 Oct 2012, 10:52 PM
After that I tried to install CMD v3 in Program Files (x86) and was not able (same problem), in Program Files also was not possible, then I used the default folder, that for some reason points to %USERPROFILE%\bin and it installed there. I really cannot understand anything, has anyone have something like this? Also other question is why the CMD installer gets the default installation folder in the user profile's folder, I don't think it is the most wanted place for Windows users...

Now I have my CMD installed and working, not where I wanted it installed but so far I can continue working.

1 Oct 2012, 11:51 PM
The default location was chosen to allow non-administrative users to install Sencha Cmd. We plan to add the "All Users" option to the installer though.

2 Oct 2012, 12:04 AM
Ok, I imagined there was something behind it. Still find it strange that I was not able to install it in Program Files, I was able to install other software. My main concern is that it just stopped at the beginning of the installation process (as shown in the screenshot in first message) with no progress or message shown.

2 Oct 2012, 12:34 AM
We use the same installer tooling so we may have the same issue in Cmd, but that is the V2 installer. Are you seeing the same behavior in Cmd V3 installer?

If so, it may be because we don't acquire admin privileges during the install and something does not handle that internally. Just a guess of course :)

2 Oct 2012, 12:38 AM
Yes, in CMD v3 I saw the same behavior and I was only able to install it under %USERPROFILE%/bin

Might be nice to show a message that the installation cannot proceed or something like that in that cases. Just for improvement ;) Thanks for your replies and your support by the way!