View Full Version : [CLOSED] Problem upgrading ST app using Cmd build 181

4 Oct 2012, 8:05 AM

I just tried to upgrade my ST 2.0.1.b3 app to the newly release 2.1.0.RC1.

Here is the output I am getting:

C:\Sencha\Projects\PPTouch>sencha app upgrade ../../ST.2.0.1.RC
Sencha Cmd v3.0.0.181
[INFO ] init-properties:
[INFO ] init-sencha-command:
[INFO ] init:
[INFO ] -before-app-upgrade:
[INFO ] app-upgrade-impl:
[INFO ] building application
[INFO ] [move] Moving 1152 files to C:\Sencha\Projects\PPTouch\.\.s
[INFO ] Renamed C:\Sencha\Projects\PPTouch\touch to C:\Sencha\Projects\P
sion.build} for backup
[INFO ] [copy] Copying 1 file to C:\Sencha\Projects\PPTouch\.\.senc
[INFO ] Updating application and workspace structure
[INFO ] Workspace does not have framework null, Copying framework to 'C:
[ERROR] Exception running app build : JavaException: com.sencha.exceptio
ns.ExState: Failed to determine framework name. Please ensure this command was
issued from either a framework or application directory
[ERROR] javax.script.ScriptException: sun.org.mozilla.javascript.interna
l.JavaScriptException: [object Error] (<Unknown source>#354) in <Unknown source>
at line number 354

I am definitely in my application directory, it's event copying the files to the backup folder. What's up here?


4 Oct 2012, 9:48 AM
It seems to have failed to detect the name of the framework being used by the application. This is controlled by the app.framework property in the .sencha/app/sencha.cfg file, which should be 'app.framework=touch' in this case.

Once the framework name is looked up, we attempt to resolve the path to that framework by looking in the .sencha/workspace/sencha.cfg file for a property named <app.framework>.dir, which should be something like 'touch.dir=${workspace.dir}/touch' .

The reason for the "workspace does not have framework null' is because we failed during the first step to resolve which framework the app is using.

Do you have values for these settings, and do they appear to line up with this pattern?

4 Oct 2012, 10:49 AM
Here is my app\sencha.cfg:


and the workspace\sencha.cfg:

# This configuration property (if set) is included by default in all compile commands
# executed according to this formulation:
# sencha compile -classpath=...,${framework.classpath},${workspace.classpath},${app.classpath}

So from what you have said, these seem to be correct?

I notice from the console window output that the touch folder in my application root gets moved into the .sencha_backup folder into another folder named '${version.major}.${version.minor}.${version.patch}.${version.build}'

So, could it be that the non presence of a 'touch' folder after it does this move be the cause of the problem here, seeing as the cfg file is telling the compiler to look for it? Or am I off track here?

I tried running the upgrade command again and get:

C:\Sencha\Projects\PPTouch>sencha app upgrade -p ../../ST.2.1.0.RC
Sencha Cmd v3.0.0.181
[ERROR] The following error occurred while executing this line:
C:\Sencha\Projects\PPTouch\.sencha\workspace\plugin.xml:2: Cannot find C:\Sencha
\Projects\PPTouch\.sencha\workspace\${framework.config.dir}\plugin.xml imported
from C:\Sencha\Projects\PPTouch\.sencha\workspace\plugin.xml

4 Oct 2012, 11:55 AM

I am being an , was my own mistake with not entering the new sdk directory to use for the upgrade correctly. I was using incorrect syntax in the console window.

App has now upgraded, sorry for wasting your time, but it was good to know about them cfg files!