View Full Version : [CLOSED] Command not found mac OSX mountain lion

7 Oct 2012, 2:59 PM
I ran the mac installer for sencha cmd. but when I type sencha into a terminal window all I get is this:

-bash: sencha: command not found

The directory was created and the files exist after running the installer. What else do I have to do?

7 Oct 2012, 8:14 PM
What version of Sencha Cmd did you install? Also, did you start a new terminal instance? The PATH environment variable is updated by a shell script that should run on terminal start.

7 Oct 2012, 10:42 PM
On Lion 10.7.4, you have to add PATH and VAR in the .bash_profile file at the root of your user folder !

export SENCHA_CMD_3_0_0="/Users/you/Path/To/Sencha/Cmd/3.0.0.XXX"
export PATH=/Users/you/Path/To/Sencha/Cmd/$PATH

7 Oct 2012, 10:56 PM
That should be done by the installer. Maybe not to that exact shell script, I'll have to check, but you should not need to add anything manually.

7 Oct 2012, 11:44 PM
Hi Don,

With the new Cmd v3 (since 144), i've to manually insert the VAR and PATH into my .bash_profile file.

The VAR and PATH are well added to the .profile file, but the "sencha" command in Terminal gives nothing. This works after having added to the .bash_profile...

10 Oct 2012, 12:06 PM
Thanks @YomeKitsuma that fixed it !!

10 Oct 2012, 12:25 PM
I have opened a bug in our bug tracker so we can look at this. Thanks!

10 Oct 2012, 10:28 PM
Thanks @YomeKitsuma that fixed it !!

Your welcome ~o)

11 Oct 2012, 12:35 PM
Having the same problem ("-bash: compass: command not found") , but I don't see the file indicated in my user root folder. Do I need to create it? I'm on 10.7.5. Thanks for any help.

I believe that is a different issue. The OP is about "sencha" being the not found command. In this case, it looks like you just need to install compass: "gem install compass". And probably restart the terminal to get compass in your PATH.

11 Oct 2012, 1:38 PM
Thanks, yeah - tried to delete in time once I realized mine was different. I've resolve my issue. Thanks for the tip. I really appreciate it.

24 Oct 2012, 11:53 PM
Same problem here in Mountain Lion 10.7.5.

When I execute these commands (with correct paths set) in the terminal it works in one terminal window.
export SENCHA_CMD_3_0_0="/Users/you/Path/To/Sencha/Cmd/3.0.0.XXX"
export PATH=/Users/you/Path/To/Sencha/Cmd/$PATH

24 Jan 2013, 12:59 AM
hey, im having the same problem
i installed sencha but the command is not found, if i export the path it does.

my path looks like this "/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin" no idea if this is good :)
i reinstalled sencha in my htdocs folder but that didnt work either

i have sencha cmd installed in user/bin and have sencha-touch-2.1.0-gpl in my htdocs