View Full Version : stbuild exited with non-zero code : 134

18 Oct 2012, 6:23 AM
I'm trying to package an app with the new cmd v3 and I'm getting this error:

stbuild exited with non-zero code : 134

what dose it mean?

20 Oct 2012, 8:26 AM
That there was an error while packaging into a native app. What that error is can be many things not to sound to generic.

20 Oct 2012, 8:56 AM
I used to be able to package it with the previous version of command tools ( v2 beta3) and same packager.json. So I was wandering about the error code to have an hint of the problem

11 Dec 2012, 12:30 PM
I have the same error packaging in Architect for Android. My application runs fine when I specify iOSSimulator.

I believe my Sencha Cmd setup and packager.json file are correct, but I don't even know where to start with this error.

I have followed http://docs.sencha.com/architect/2/#!/guide/deploy

Any advice would be appreciated.

11 Feb 2014, 7:11 AM
I had this very same issue, solved it by adding all keys that were missing in the packager.json file (keys like provisonProfile, notificationConfiguration, etc). I also ensured that all key values were strings and not ints, etc.

Ex: "versionCode": 17 instead of "versionCode": "17".