View Full Version : Sencha Command - ST2 - MicroLoader error on 3g

24 Oct 2012, 3:06 AM
I have a application that updates just fine on WiFi. But when the phone are on 3G and there is an update available i get this error:

TypeError: '3' is not a function (evaluating 's(g,c)')
I have tried with B3 and Sencha Cmd V3 Beta with the same result.

24 Oct 2012, 7:16 AM
I have found the problem.
After a lot of debugging my co-worker code I found that there where a for loop without 'var' and s as variable name.
So I guess when inserting/minifeing the microloader it creates a global variable named s too. Then somehow there can be timing issues when the code is run on slow connections.

Would it not be a good idea to isolate the microloader code a little better?

24 Oct 2012, 6:58 PM
This was in the microloader? Which one, I did not see a global s variable just looking at the source.

24 Oct 2012, 11:18 PM
The minified microloader that replaces

<script id="microloader" type="text/javascript" src="sdk/microloader/production.js"></script>
in index.html when building has s I think it might be a function but I am not sure, its hard to read minified code.

25 Oct 2012, 4:13 AM
Yeah but you can find that file unminified if you look at the microloader directory in the 2.1.0 RC2 release.