View Full Version : [NOREPRO] Store won't load XML: TypeError: 'undefined' is not an object (evaluating 'b.length')

24 Oct 2012, 8:06 AM
Tried following the instructions for loading XML into a store. Went through the process contained here:

three times. Each time, when an attempt is made to load the data, the following message occurs:

TypeError: 'undefined' is not an object (evaluating 'b.length')
Source Class: qrc:/designer/src/frameworks/ext41/framework/ext-all.js?0.7041799214202911 Line 18

Has anyone successfully loaded XML data with Architect before? Is there something I'm missing?


24 Oct 2012, 10:05 AM
Could you give us some more details about your build

25 Oct 2012, 11:48 AM
It is build 640 Sencha Architect 2.1.0

Hope that helps,


31 Oct 2012, 10:13 AM
Rob -

If you open the url that is being used to load the xml in the browser does the xml appear properly? Is the webserver interfering here and passing back some weird content (possibly?)

We've been unable to repro.

31 Oct 2012, 12:36 PM
The xml loads fine in the browser. To prove to myself that it was pulling off the local web server I build a simple open-and-display xml (the xml file in question) from Visual Studio 2012 and that worked fine when loaded in the browser.

Would you like screen shots? A copy of the file? I haven't been able to get very far with this program. Hope I'm not being dense here.

31 Oct 2012, 12:52 PM
Sorry for your troubles, we'll try to resolve it.

Could you create an archive of the project that we can test out here?

31 Oct 2012, 1:21 PM
Ext version 4.1.1a
Sencha Architect version 2.1.0 Build 640
Chrome 22.0.1229.94 m

31 Oct 2012, 2:01 PM
Rob -

Thanks for the help, was able to isolate this one and confirm its existence in build 640. This bug is already fixed in the next patch release that will be coming out soon.

1 Nov 2012, 5:26 AM
It's always good to know it wasn't because I was doing something stupid.

Meanwhile, am I dead in the water as far as using XML in the Architect IDE until the next build is available?

1 Nov 2012, 7:58 AM
Well I wouldn't go so far as to say "dead in the water" but you are correct in saying previewing the xml inside of Architect will not work. You do not have to click "Load Data" to continue working with xml data.

The next patch release is coming up soon.