View Full Version : [CLOSED] 'sencha generate model' not working in Sencha Cmd v3.0.0.230

26 Oct 2012, 9:17 AM
Just to test, use the exact instructions over at

run '' sencha generate model User --fields=id:int,name,email "

I get this error :
Sencha Cmd v3.0.0.230
[ERROR] --fields=id is not a valid field name
[ERROR] Invalid Field Name

I tried different field names, etc, but no luck.


26 Oct 2012, 9:35 AM
The guide you are linking to is for the old Sencha Command. Sencha Cmd is a complete rewrite so things are the same in all cases. The command you should use for the above should be:

sencha generate model User id:int,name,email

User is the name and 'id:int,name,email' are the fields.

26 Oct 2012, 9:46 AM
worked :)
thanks mitchell !

is there a doc somewhere that shows the differences , or not published yet ?

26 Oct 2012, 9:51 AM
Since 2.1.0 is not GA quite yet the online docs will still show 2.0.x which Cmd does not work with. f you look at the docs for 2.1.0 RC2 the Sencha Command guide is not there anymore. We will continue to improve the Cmd docs also