View Full Version : [FIXED] Build version does not support UTF8?

27 Oct 2012, 3:15 PM

When building the application with Sencha Cmd, the generated code is re-encoded in ANSI and UTF8 characters do not display correctly.

My tab, dev version (OK):

My tabs, build prod:

Any way to force the character encoding?
Shouldn't Sencha default to UTF8?

28 Oct 2012, 5:17 PM
The short answer is "yes, the build is supposed to generate UTF-8 output", but without a precise set of steps it will be just guessing where the encoding went wrong.

Can you include the steps you've taken here?

Thanks for the report!

29 Oct 2012, 4:21 AM
Well I follow an uncommon process...

I have an application created first with Sencha Architect 2.1, then updated manually when my trial expired.
This code is supposed to work with Sencha SDK Tools 2, but it does not work very well...
So why not trying the new one.

Here is what I did:
- generated a sencha touch 2.1rc2 app with sencha cmd 3
- moved to that folder, removed everything under app/ and replaced it with my own app
- then edited app.js: added my models/views/stores/controllers, renamed the app, and changed the first view to create in the launch() method.
==> everything works perfectly!
- then I built the app, and the built version is encoded in ANSI so the Japanese/Chinese characters are not displayed

So at that point, I thought it might be because app.js itself is in ANSI (as I kept and edited the auto-generated one) so I converted it to UTF-8 without BOM (as Sencha Architect 2.1 creates files in this character encoding) but it did not solve the issue (it was either still not showing correctly, or even saying there is an error in app.js line 56, not expected character).

I ended up changing the tab name in English and it works well (UTF-8 characters loading from Ajax calls are displayed correctly).
I deployed on dotcloud for testing from a smartphone and it works well: http://keio-sdmnews.dotcloud.com/
But it would be great if Sencha could encode by default in UTF-8.

30 Oct 2012, 12:12 AM
I'm going to open a ticket for this to see if we can reproduce the issue - the code generated by Sencha Cmd is supposed to be UTF-8 so this would certainly be a bug.

31 Oct 2012, 10:02 PM
can you zip the input file with the special characters and the resulting output file? Please zip and attach to this forum to preserve the encoding.

4 Nov 2012, 9:48 PM
My suspicion is that there is actually in input issue here because we always write output in UTF-8. So for the wrong content to appear in the output file, it almost certainly originated from a file where we did not understand the character set.

On a JavaScript file you may need to do this on line 1:

//@charset ISO-8859-1

The list of supported charsets can be found here:


Please ensure the file are either encoded in UTF-8 (the assumed encoding) or starts with a declaration like the above. If you are still having problems, please post some fragment of the source file and output for me to look at.

23 Apr 2015, 5:01 PM
I'm using sencha extjs 5.1, build my app with the command "sencha app build" and later wrapped it inside war file coz i deploy on the glassfish server. But nothing works! :( the app stills showing characters incorrectly.In the index.html i have this: At the beginning of every js file://@charset UTF-8Also i have this on sun-web.xml
would anybody help me please ??

30 Apr 2015, 5:46 AM
Same problem for me. Using Sencha Cmd version and tried the nightly builds, too.

1 May 2015, 8:35 AM
What is the version number of the nightly you tried? We believe this is fixed in Cmd 5.1.3 nightly and will be released soon.

6 May 2015, 11:03 PM
Same problem here. We're using Sencha Architect and the versions, according to Architect About info are:

Architect version:
channel: 3.2-stable
framework: Ext JS 5.1.x

6 May 2015, 11:38 PM
Same problem here. We're using Sencha Architect and the versions, according to Architect About info are:

Architect version:
channel: 3.2-stable
framework: Ext JS 5.1.x
I have same problem too

8 May 2015, 8:26 AM
Please try Cmd 5.1.3 - we believe it fixes this problem - https://www.sencha.com/forum/showthread.php?300893-Sencha-Cmd-5.1.3-GA-is-Now-Available

3 Oct 2015, 4:52 AM
Same problem here.

framework: ""