View Full Version : [FIXED] Apps in Workspaces in Cmd V3.0.0.230 have wrong default ext image paths

30 Oct 2012, 12:42 PM

Win7 64 bit
Sencha Cmd V3.0.0.230
ExtJS 4.1.1a

sencha -sdk path/to/4.1.1a generate workspace C:\TestWrkspace
sencha -sdk path/to/4.1.1a generate app Test C:\TestWrkspace\Test
navigate to C:\TestWrkspace\Test
sencha app build
navigate to C:\TestWrkspace\build\Test
Open index.html
Notice the following error in console:
Failed to load resource file:///C:/TestWrkspace/build/ext/resources/themes/images/default/tab-bar/scroll-right.gif

It looks like when you create the app inside of the workspace, the path to the images is being written incorrectly.

It is looking for the images in the following path:
They actually exist here:

Any help would be appreciated.

31 Oct 2012, 9:46 AM
Thanks for the report! I have opened a bug in our bug tracker.

2 Nov 2012, 12:10 PM
Sencha Cmd v3.0.0.230
Ext JS 4.1.2a (Ext.getVersion('extjs') reports

My app name is LP...

I'd just like to make sure that the bug described in this thread is the same as what I'm experiencing since I do not use a workspace. Basically, when I build the app (with sencha ant build), the images are being generated in build/LP/resources/images/default/, yet the references in the CSS files all point to build/LP/ext/resources/themes/images/default. Is this a bug, and if so is it the same bug? If not, perhaps I'm missing a configuration parameter somewhere?

2 Nov 2012, 1:40 PM
That's odd. I don't have the same problem when I create just an App and no workspace using 4.1.1a. I'll have to give it a go when I have a second with 4.1.2a

3 Nov 2012, 5:49 AM
For my own sanity I just tried this again from scratch. I created a new directory, and then from within that directory, I ran:

sencha -s ../extjs/ext-4.1.2a generate app LP .
sencha ant build

Images were generated in build/LP/resources/images/default/, but they are never referenced in the CSS file (build/LP/resources/css/app.css).