View Full Version : Sencha app build production error

1 Nov 2012, 7:44 AM
I have similar problem that others have had but I have compass installed. The other posts I have seen is because of compass. My log trace doesn't specify compass. I am using Sencha Cmd and Sencha Touch 2.1 rc2

[INFO ] init-sencha-command:
[INFO ] init:
[INFO ] -before-app-build:
[INFO ] app-build-impl:
[INFO ] testing:
[INFO ] -before-init-local:
[INFO ] -init-local:
[INFO ] -after-init-local:
[INFO ] init-local:
[INFO ] find-cmd:
[INFO ] -before-init:
[INFO ] -init:
[INFO ] -after-init:
[INFO ] init:
[INFO ] -before-build:
[INFO ] page:
[INFO ] -before-page:
[INFO ] -page:
[ERROR] java.lang.StackOverflowError
[ERROR] at java.security.AccessController.doPrivileged(Native Method)
[ERROR] at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
[ERROR] at sun.misc.Launcher$ExtClassLoader.findClass(Launcher.java:229)
[ERROR] at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
[ERROR] at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
[ERROR] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
[ERROR] at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
[ERROR] at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
[ERROR] at java.lang.ClassLoader.loadClass(ClassLoader.java:295)

5 Nov 2012, 7:21 AM
You should run with the debug flag to see what everything is going on

sencha -d app build production

Also did you try testing build first?

5 Nov 2012, 9:09 PM
I was able to get it too build. I ran and update however that removed everything out of the touch folder for some reason. I went ahead and generated a new app, copied the touch folder, recompiled my sass and ran the build again. I don't understand what that was all about but it worked.

I also found in my .bashrc file and .profile file other export references to older versions of sencha tools and cmd which I commented out. So I am not a exactly sure what made the difference.

Mitchell thanks as always for your assistance.

22 Jul 2015, 10:54 PM
could you please explain me process of build production build , i am Using extjs4.1.0 and cmd vesrion 6. i am new to mac so please explain me process from scratch. i am using mac Yosemite OS.