View Full Version : CMD Generate App not working with _ in path name

16 Nov 2012, 10:25 AM
I am using the 32 bit Linux version of the Cmd App. And am almost bald from pulling my hair out with this problem. :((

I had been trying to build an app with the app path of /home/username/Web_Projects/appname. Username and appname being a place holder. It kept failing with the error message: [ERR] app config specified framework touch, but could not determine path [ERR] could not determine path to framework.

I had tried building from the SDK dir, using the -sdk command to point to the sdk, reinstalling the sdk, just about everything I could think of. No such luck. Then just as I was about to give up on using Sencha, I took the _ out of the app path and what do you know, it ran fine. I tested several other options including putting the _ back in and always got the same result. _ bad, no _ good. I hope I posted this bug in the right forum. Thank you for your hard work.

19 Nov 2012, 3:28 PM
That sounds odd - can you post the exact command you executed and the log you get? Maybe something like:

sencha -debug generate app App1 /path/to/app_dir

21 Nov 2012, 6:27 AM
I am not sure where to find the log. I posted the exact wording of the output when I ran the command sencha -sdk ~/Sencha/SDK generate app Money ~/Web_Projects/.

I did the same command but with the app dir set teo ~/Temp/ or something similar and it generated just fine. I ran it several other ways. It just doesn't like the _ in the app path.

21 Nov 2012, 9:45 AM
Sorry for the terminology there - by "log" I mean the console output produced. You can capture it with "> log.txt" on the end of the command line.

We'll try the steps you described and see what we see, but the log output is often helpful once "-debug" is enabled.