View Full Version : No output returned for Sencha Cmd 3.0

21 Nov 2012, 12:51 PM
I installed Extjs 4.1.1a and Sencha Cmd on my Window XP Professional machine. When I type in 'Sencha' in the dos window I should get 'Sencha Cmd v3.0.0', however I get no output. I made sure I ran the command in the Extjs SDK folder (c:\sencha\ext-4.1.1a). My understanding is I do NOT need SDK build tool when using Extjs 4.1.1a and Sencha Cmd. I tried setting it up on my home pc (Windows 7) and the command runs fine. Any help would be appreciate. Thanks!

4 Dec 2012, 8:23 AM
Update on problem. I installed a newer version of the Java SE runtime (version 1.6 update 37) and the command line works OK. Had an older version of the Java 1.6 runtime.

5 Dec 2012, 11:01 AM
You can hack the 'sencha' shell script to see the error that's occuring. By default, it seems to output stderr to a file called 'stderr.txt', but then deletes it before the program exits. So if there's an exception, you just get blank output.

MAKE A BACKUP COPY ?of the sencha command first.

Look for this line:

java $jvmArgs -jar $BASEDIR/sencha.jar "$@" 2>stderr.txt

Remove the redirection of stderr to stderr.txt, so the line now reads:

java $jvmArgs -jar $BASEDIR/sencha.jar "$@"

Now, if there is a Java exception, you'll see the stack trace on the console so you have an idea of what's wrong.

5 Dec 2012, 11:04 AM
Sorry, I just realized you said you're on Windows XP. The steps I mentioned above only work on a Mac or Linux system, or on Windows if you're using cygwin. If you're running on just plain Windows, it runs the sencha.exe file, which of course you can't modify.