PDA

View Full Version : ext.ux.data.BufferedJsonReader superclass error



ppogoda
1 Feb 2008, 12:24 AM
Hi!

I'v got very strange problem while trying to use ext LiveGrid extension and extJS base lib in debug mode in normal 'compressed' mode everythink works fine.

my js include order is:
1. Ext.js from src/core/Ext.js
2. ext-base.js from src/adapter/ext-base.js
3. ext-all.js from ext-all.js

4. ext/ux/widgets/grid/BufferedGridView.js
5. ext/ux/widgets/grid/BufferedRowSelectionModel.js
6. ext/ux/widgets/grid/BufferedStore.js
7. ext/ux/widgets/BufferedGridToolbar.js
8. ext/ux/data/BufferedJsonReader.js

I also include before this extJS script other js libs used in our project: prototype, yui, jquery.
Like I said if 3. is ext-all.js everything works fine, but if I change it ext-all-debug.js -> ext-all.js I receive js error while creating BufferedJsonReader:
Ext.ux.data.BufferedJsonReader.superclass has no properties (BufferedJsonReader line 16)

It seems that Ext.extend stop working but I have no idea why :/
I try to debug it using FireBug (found extend definition in Ext.js) but with no result/solution - placing breakpoint in extend method result in browser crash or bring Java console (very strange).

In debug mode it won't work on any from my web browsers trying: firefox 2/3, ie 6/7, opera, safari.

Maybe in 'debug' mode i need to include some other file to ?

Have a nice day
Paul