View Full Version : [OPEN] Issues with Sencha Cmd 3.0.1 and Sencha Touch 2.1

22 Dec 2012, 1:35 PM
Using Sencha Cmd 3.0.1, when I run "sencha generate app [appName] [appPath]" from a Sencha Touch 2.1 SDK directory, the packager.json file contains:

* @cfg {String} certificateAlias
* This is the name of your certificate.
* IF you do not specify this on OSX, we will try and automatically find the certificate for you using the applicationId.
* This can be just a simple matcher. For example, if your certificate name is "iPhone Developer: Robert Dougan (ABCDEFGHIJ)", you
* can just put "iPhone Developer".
* When using a certificatePath on Windows, you do not need to specify this.
* @cfg {String} certificatePassword
* The password which was specified during certificate export
* @cfg {String} provisionProfile
* The path to the provision profile (APP_NAME.mobileprovision) which you can create and then download from Apple's provisioning portal

The certificateAlias value is missing, and the certificatePassword and provisionProfile values are in the wrong place. The same thing happens when I upgrade an existing ST 2.1 app.

Also, when I upgrade an existing ST 2.1 app, all the comments are removed from the app.json file.

Finally, if I run "sencha generate app" with no arguments, I get:

$ sencha generate app
Sencha Cmd v3.0.1.283
[ERR] sencha.generate.app requires these parameters:
path (The path for the generated application)

This is wrong; it requires two parameters, the app name and the path.

26 Dec 2012, 11:36 AM
Thanks for the report! I have opened a bug in our bug tracker.