View Full Version : Simulate error

27 Dec 2012, 9:03 AM
I nearly finished an iPad app using Sencha Architect, which is great. I created a new project to test out some functionalities and when I tried to simulate the new project Terminal spawned the following error:

Sencha Cmd v3.0.0.250
[DEBUG] Session could not be started: Error Domain=DTiPhoneSimulatorErrorDomain Code=1 "iOS Simulator failed to install the application." UserInfo=0x7fcbcb800850 {NSLocalizedDescription=iOS Simulator failed to install the application., DTiPhoneSimulatorUnderlyingErrorCodeKey=-1}
The application was successfully packaged

[ERR] stbuild exited with non-zero code : 1

[Process completed]
Weird thing is that all of a sudden simulation in both projects results in the same error. It all worked fine in the first project; preview and build still function but simulation doesn't work anymore.

I tried using another SDK for simulation -iOS 5.1- but the same error keeps popping up.

My guess is that there is something wrong with Apple Xcode, anyone out there who has experienced the same thing? Or am I thinking in the wrong direction?

Specs: OS X 10.8.2, Sencha Architect 2.1.0, Xcode 4.5.2 and Sencha Command


27 Dec 2012, 11:30 AM
It appears that the simulation environment stacks up data... I fixed the problem by selecting 'Reset Content and Settings...' inside the running simulator.