PDA

View Full Version : Version conflict in an integration application



dpclark
15 Jan 2013, 1:38 PM
We have two applications. One hosts the other in an iframe. They both leverage extjs but use different versions. We're seeing an exception where the EventManager is potentially null or undefined. Is there a best practice to having multiple version potentially included?

mitchellsimoens
17 Jan 2013, 9:03 AM
Here's an answer that I'm sure you won't like, sounds like you need to upgrade the old app. Personally my best practice would be don't load two frameworks

dpclark
17 Jan 2013, 1:10 PM
That was my guess but I held out a modicum of hope that there was an easy work around