PDA

View Full Version : SOAP Proxy not included in ExtJS 4.2.0.663



schiesser
16 Apr 2013, 1:53 AM
I just download the Sencha Complete Package containing ext-4.2.0-commercial.zip. This Package does not contain the SoapProxy as expected.

Therefore the SOAP Grid example (/ext-4.2.0.663/examples/grid/soap-grid.html)
does not work and delivers a:

Uncaught TypeError: Cannot call method 'substring' of undefined

Probably because the SoapProxy is not registered.

Where can I find the SoapProxy?

evant
16 Apr 2013, 3:14 AM
Those data proxies are part of Sencha Complete: https://www.sencha.com/store/sencha-complete

schiesser
16 Apr 2013, 3:51 AM
I know, from there I downloaded SenchaCompleteTrial-1.0.0.56-windows.exe

which contains:
Sencha Touch 2.1.1
Sencha Eclipse Plugin 2.1
SenchaArchitect and
ext-4.2.0-commercial.zip

I expected the SoapProxy to be inside of the last archive, but it isn't.

slemmon
17 Apr 2013, 2:54 PM
In the SDK folders are you seeing src / data / soap?

schiesser
17 Apr 2013, 8:53 PM
No it is not there

hisham.javed
17 Apr 2013, 9:59 PM
I'm also facing this problem. I can't see any soap folder under src/data. Support please answer this question also sencha API soap example is not working from the following url

http://docs.sencha.com/extjs/4.2.0/#!/example/grid/soap-grid.html

P (http://docs.sencha.com/extjs/4.2.0/#!/example/grid/soap-grid.html)lease respond this question ASAP. Its urgent

slemmon
18 Apr 2013, 2:59 PM
In the Complete-Trial folder do you have a folder of "1.0.1.15" and under that "ext-4.2.0.633" > "src" > "data" > "soap"?

I just downloaded and installed the Complete Trial and that's what I see in my directory structure. In the soap directory are the Proxy and Reader classes for soap.

hisham.javed
18 Apr 2013, 8:35 PM
No I can't see soap folder under "ext-4.2.0.633" > "src" > "data" > "soap".

Also please answer that why soap example is not working
http://docs.sencha.com/extjs/4.2.0/#!/example/grid/soap-grid.html

slemmon
18 Apr 2013, 10:14 PM
When I installed the Complete Trial it installed everything under a folder of "1.0.1.15". Can you tell me what version you see?

hisham.javed
18 Apr 2013, 10:26 PM
I don't remember exactly from where I download ext-4.2.0.663 actually my company purchased license of Sencha ExtJs and they provided me this SDK.

But for personal use I downloaded trial version 1.0.0.49 which has ext-4.1.1a-commercial.zip. I also found that this SDK has empty soap folder too.

slemmon
19 Apr 2013, 10:04 AM
Complete started including SOAP adapters starting with the 4.1.2 build. Perhaps that's why it was not in your download?

hisham.javed
21 Apr 2013, 8:30 PM
I'm using ext-4.2.0.663. This is a big mistake at your end.

anad2312
11 Jul 2013, 7:42 AM
I really need to test Sencha out using the soap proxy. If I do not have it, then Sencha is a waste for me. Why is the soap folder empty for 4.2.1.883?????