PDA

View Full Version : [FIXED] [4.2.0] Ext.Updater atavism in locales



Daniil
22 Apr 2013, 2:28 AM
REQUIRED INFORMATION

Ext version tested:

Ext 4.2.0

Description:

There is an atavism in locales. For example, the Russian locale:


if (Ext.Updater) {
Ext.Updater.defaults.indicatorText = '<div class="loading-indicator">???? ????????...</div>';
}

Likewise in the other locales (I checked a few).
I guess there is no Ext.Updater class anymore and this should be removed. Please correct me if I am wrong.

evant
22 Apr 2013, 3:01 AM
You're quite right. I recently went through and removed them (a couple of weeks ago). They don't hurt anything, but they don't need to be there.

Daniil
22 Apr 2013, 3:25 AM
Argh, I am late:)

Thank you, Evan.

By the way, this bug AbstractView loadingText and LoadMask msg are not localized (http://www.sencha.com/forum/showthread.php?245783) is related to the problem.

I mean that Ext.Updater is an atavism, but a loading text in not localized so far.

At the moment the locales looks a bit frozen (I mean that there are quite many issues). I remember you and Mitchell have been saying that there is a big ticket for the locales, something like "to revamp", but, seems, I can't see any significant progress on this. Well, if you have any comments on this, I would much appreciate to hear something.