PDA

View Full Version : missing dependencies in trying to install Sencha plug-ins to Eclipse



cpaul
23 May 2013, 1:53 PM
I am trying to get Sencha Complete installed and running. I have followed the instructions provided to install the plug ins to Eclipse Indigo but I get the following error:

Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse VJET JavaScript IDE (Incubation) 0.10.0.201303090118 (org.eclipse.vjet.js.ide.feature.group 0.10.0.201303090118)
Missing requirement: Apache Batik CSS 1.7.0.v201011041433 (org.apache.batik.css 1.7.0.v201011041433) requires 'package org.w3c.dom.events [3.0.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: Eclipse VJET JavaScript IDE (Incubation) 0.10.0.201303090118 (org.eclipse.vjet.js.ide.feature.group 0.10.0.201303090118)

I have done clean install of JRE7 and Eclipse Indigo 3.7 but keep getting the same error. I've found a few mentions of it via Google but can't find anyone who has a solution. Has anyone else had this issue and been able to solve it?

Thank you in advance

slemmon
29 May 2013, 9:24 AM
Let me engage the product team on this to see if we can help troubleshoot. What operating system or systems are you running when installing the plugins? Any other version or versions of Eclipse attempted?

cpaul
29 May 2013, 10:06 AM
Thank you so much! It's running on Windows 7 (32 bit). I've also tried the latest version of Eclipse Juno but got the same error.

DNRDustin
29 May 2013, 8:20 PM
Missing requirement: Apache Batik CSS 1.7.0.v201011041433 (org.apache.batik.css 1.7.0.v201011041433) requires 'package org.w3c.dom.events [3.0.0,4.0.0)' but it could not be found
Cannot satisfy dependency:

eclipse is telling you what you need

cpaul
29 May 2013, 8:40 PM
Um, I am aware of what is missing but multiple Google searches have not told me where to find this. I am just starting out with Sencha and followed all of the instructions with regard to installing this plug-in. I have tried multiple fresh installs of both Eclipse Indigo and Eclipse Juno with the same error. I'm not sure why this would be missing or where to locate it.

DNRDustin
29 May 2013, 9:17 PM
check to see whats already installed in eclipse, maybe you can update if it's there.
check for software in eclipse from the available sites, then install what you need from there.
go to there website and look for the appropriate plugin.

Google : Apache Batik CSS 1.7.0 eclipse plugin

cpaul
30 May 2013, 8:43 AM
Thank you. I found the plug-in that was missing and got it all installed. I'm not sure why I was unable to find any repositories for this plug in last week but found it today. Oh well, live and learn. Thank you for prodding me to keep looking.

DNRDustin
30 May 2013, 10:51 AM
glad to hear you got it figured out!

kpiland
24 Jun 2013, 8:59 AM
I had a similar issue to this trying to install the Eclipse plugin. I'm running Juno SP2.
The error message that I got was:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.w3c.dom.events,3.0.0.draft20060413_v201105210656

Based on this post, I assume it was a similar missing dependency - probably the same one, but it doesn't state what's missing as clearly.

My workaround (perhaps not a great one) was to install VJET from the Eclipse marketplace, which brings along its necessary dependencies. I then tried to just install the Sencha plugin, but it complained about compatibility with the version of VJET that I installed (even though they were created within a couple of weeks of each other). After uninstalling VJET, though, I could then successfully install the VJET version included with Sencha plugin as well as the Sencha plugin. I'm guessing either the marketplace version of VJET left behind whatever dependency was missing from the Sencha bundle, or it cleaned up something that was not quite right in what I already had installed.

deka
26 Jul 2013, 6:52 AM
Getting the same error "No repository found containing: osgi.bundle,org.w3c.dom.events,3.0.0.draft20060413_v201105210656" when trying to install the VJET javascript IDE from this update url "http://download.eclipse.org/vjet/updates-0.10".

I used the Eclipse Marketplace and search for VJET and install it. That is how it worked for me.

tdobberphul
14 Nov 2013, 7:09 AM
Thank you. I found the plug-in that was missing and got it all installed. I'm not sure why I was unable to find any repositories for this plug in last week but found it today. Oh well, live and learn. Thank you for prodding me to keep looking.

Hi,
could you please tell me where I find this exactly?
I have the same problem and cant get sencha complete eclipse plugin to work.

Thaks a lot,
Tobias

alperse
5 Mar 2014, 2:43 AM
In Eclipse go to Help-->Install New Software
Click on the link (on top right) "Available Software Sites"
Replace http://download.eclipse.org/releases/kepler with http://download.eclipse.org:80/releases/kepler