PDA

View Full Version : Black area under menu in menubar



jeet_sen
29 May 2013, 10:44 PM
In latest version of Chrome (27.0.1453.94 m), after the mouse leaves a menu in a menubar, a black area continues to get displayed (where the menu was being displayed). In the previous version of Chrome (26.x), it works fine. Is this a Ext JS bug or Chrome problem?

Note: a workaround to this problem is disabling "hardware acceleration when available" from Chrome Advanced Settings.

mpost
30 May 2013, 8:44 AM
I'm also seeing this with Ext 4.1.1a for any floating menu elements (drop down buttons, context menus, etc). I'm guessing it's a Chrome bug, but that's pure speculation based on the behavior I've seen.

31 May 2013, 12:10 AM
Same here introduced with the latest Chrome update - have seen this in the latest beta of Chrome.

slemmon
31 May 2013, 12:21 PM
I've seen others reporting the same issue with Chrome 27. I don't get it myself so can't test, but I hear this is the workaround for now.

Click drop-down menu on top-right corner –> click “Settings” –> click “Show advanced settings…” on the bottom –> scroll to the bottom, and uncheck “Use hardware acceleration when available”.

... and just saw jeet_sen's note about the same fix. :)

mpost
3 Jun 2013, 2:55 PM
Has anyone from Sencha filed a bug with the Chrome team? I figure a framework vendor carries more weight than a random developer such as myself.

slemmon
3 Jun 2013, 5:23 PM
I believe it's already a know issue. Here's the bug report I'd seen:
http://code.google.com/p/chromium/issues/detail?id=245229&q=black&colspec=ID%20Pri%20M%20Iteration%20ReleaseBlock%20Cr%20Status%20Owner%20Summary%20OS%20Modified

mpost
3 Jun 2013, 5:26 PM
Excellent, I had not seen that. Thanks much!