PDA

View Full Version : SenchaCmd Compass and SASS



RudyBone
31 May 2013, 5:19 AM
I am working in a limited (in terms of Internet access) environment. I have access to the ExtJS lib and SenchaCmd however my linux environment does not currently include either Compass or Sass. The SenchaCmd user guide says that I need to 'gem install compass'. Do I really need to go out to the internet to do this? Isn't Compas/SASS included as part of the SenchaCmd package I installed and if so, where are their gems located and how can I install them?

LesJ
31 May 2013, 6:29 AM
I am working in a limited (in terms of Internet access) environment. I have access to the ExtJS lib and SenchaCmd however my linux environment does not currently include either Compass or Sass. The SenchaCmd user guide says that I need to 'gem install compass'. Do I really need to go out to the internet to do this? Isn't Compas/SASS included as part of the SenchaCmd package I installed and if so, where are their gems located and how can I install them?

SASS and Compass (correct versions) should be included by Cmd. I had no issues on a Mac.

RudyBone
31 May 2013, 12:25 PM
I see som Compass and Sass related directories in the SenchCmd directories. Don't I have to install both Compass and/or SASS as Ruby Gems? If so how do I this?

LesJ
31 May 2013, 1:00 PM
Cmd will install SASS and Compass ensuring that you have compatible versions. You will be able to use them right away, see the doc:

http://docs.sencha.com/extjs/4.2.1/#!/guide/command