View Full Version : ExtJS 4.2 problem while compiling css

30 Jun 2013, 11:39 PM

i recently stated to switch from ExtJS 4.1 to 4.2.1 and got a problem with the SCSS / CSS compile process.

I followed the Theming guide on this page: http://www.sencha.com/learn/theming/.

And i also copied the images from appname/extjs/resources/themes/images/default to appname/resources/images.

Although our directory structure is a bit different:



I am having Compass 0.12.2 installed on my development machine.

When i run "compass compile appname.scss" in /resources/sass/ i get the following warning:

WARNING: @theme-background-image: Theme image not found: ../../resources/themes/images/appname/tools/tool-sprites.gif
on line 18 of D:/htdocs/appname/src/resources/themes/stylesheets/ext4/default/mixins/_theme-background-image.scss
The warning block ends with
identical ../css/ext-appname.css

Although when i start from "/resources/sass" and follow the relative path "../../resources/themes/images/appname/tools/tool-sprites.gif" i end in "/resources/themes/images/appname/tools/tool-sprites.gif" and that file definitely exists and is readable.

In my config.rb file its:

$ext_path = "../.."
This seems to be right and everything worked fine with ExtJS 4.1.

I am not quite sure what to do now.
I hope someone may give me a hint how to continue.
Thank you in advance!

9 Jul 2013, 3:50 PM
You might try setting "$image-search-path" as a variable in your sass file to point to the directory with the image resources. That should resolve the path issue kicking up the warning.

You'll also potentially need to set one more variable.
If your copied images sit in a folder named 'images' in the same directory as your CSS output then you should be fine. Otherwise you'll need to set the path for "$ext-theme-neptune-resource-path" where neptune will be your theme's name you're working with.

10 Jul 2013, 1:27 AM
First of all thank you for your answer.

Although i am having still trouble with this:

In my theme sass file (.scss) i added the variable

$image-search-path: but no matter what i enter as the value the warnings while compiling remain the same. Even if i test
$image-search-path: "/123/"; there is not "123" in the warning paths i see on the console output from compass.
I thought i maybe edited the wrong file but when i change the
$theme-name to something else i see the wrong theme name in the console output.

So i am still stuck with this problem and ExtJS 4.1.
I would really like to upgrade my whole project but without correct compilation of the theme i can't.
Maybe you can help me a second time.