PDA

View Full Version : Windows 7 IE* - Tab not loading data in winxp it's fine



nitingautam
13 Jul 2013, 4:59 AM
Hi,

I am using ext js 3.3.x version in which inside a tab i am loading a IFRAME with a form. In winXp IE8 it works fine but on win7 IE8 the tab data which is iframe not loading at all.

In one function first I am creating iframe as below:



caseIntakeIframe = document.createElement("iframe");
caseIntakeIframe.setAttribute('id', 'caseIntakeFrame');
caseIntakeIframe.setAttribute('border', 'none');
caseIntakeIframe.setAttribute('frameborder', '0');
caseIntakeIframe.setAttribute('style', 'overflow-x:scroll;overflow-y:scroll;');
caseIntakeIframe.setAttribute('scrolling', 'yes');
document.body.appendChild(caseIntakeIframe);
caseIntakeIframe.setAttribute('src', 'some address');


after that uising below command adding to 'case123' tabpanel, so I noticed inside Win7 that Iframe created successfully in body but adding of this to the tab is not working whereas in Winxp it is fine... please suggest..


Ext.getCmp('case123').add(caseIntakeIframe);

Additional thing , in win7 IE8,9,10 when I Tab ccontent try to load i get a permission denied in below line of ext-all-debug file...In winxp ie 8 I get this permission denied in another line but there content loads whereas in win7 not



ext-all-debug.js
createElement : function(name, pnode){
.....
this[name] = Ext.get(pnode.appendChild(el));

Just to mention that case123 do exist

nitingautam
13 Jul 2013, 9:28 AM
Resolved with


Ext.getCmp('case123').body.appendChild(caseIntakeIframe)