PDA

View Full Version : ext-4.1.1a to ext-4.2.1 | ComboBox inline editing in



olof
16 Jul 2013, 11:50 PM
We are trying to upgrade from ext-4.1.1a to ext-4.2.1 but the previously working combo box below is preventing plugin.RowEditing from working. When you double click to bring up the edit bar you receive the errors shown below.

Any ideas chaps....?

Many thanks in advance for fresh eyes on this!!

Olof



var categoryComboEditor = Ext.create('Ext.form.ComboBox', {
triggerAction : 'all',
editable : false,
allowBlank : false,
displayField : 'name',
valueField : 'id',
queryMode : 'local',
store : Ext.create('Ext.data.Store', {
fields : ['id','name'],
data : categoryData
})
});




{
id : 'category',
header : 'Category',
dataIndex : 'category',
sortable : true,
width : 152,
renderer : function(val, meta, record, rw, cl, st) {
return (record.get('categoryName'));
},
field : categoryComboEditor
},


We are seeing the following debug errors:

Uncaught TypeError: Cannot call method 'getHeight' of undefined
Uncaught TypeError: Cannot call method 'isVisible' of undefined

olof
17 Jul 2013, 2:49 PM
Is this issues the way I used field?



field : categoryComboEditor,

slemmon
18 Jul 2013, 3:41 PM
What if you use 'editor' instead of 'field'?