PDA

View Full Version : Maximized panel didn't render correctly on chrome.



k_cire0426
2 Aug 2013, 3:15 AM
REQUIRED INFORMATION

Ext version tested:

Ext 4.2.1
Browser versions tested against:

Google Chrome Version 28.0.1500.95 m
DOCTYPE tested against:

html
Description:

Window does not render correctly on chrome when maximized and chrome has "Ask Toolbar".
Steps to reproduce the problem:The result that was expected:



I have a window that sets to maximize when show. The window set also as initial view.

The result that occurs instead:

The window shows behind the "Ask toolbar". This was not happening on firefox.
HELPFUL INFORMATION


I have attached the screenshot.
Operating System:

Windows 8

k_cire0426
2 Aug 2013, 3:16 AM
Do you have any workaround on this?

dominic_u
2 Aug 2013, 8:03 PM
Can we have a workaround? :)

evant
2 Aug 2013, 10:18 PM
1) No, this isn't a bug. The toolbar inserts itself as a floating container in the DOM, it's not part of the browser at all, rather it's dynamically inserted into the page.

2) We can't support addons for browsers, because once you support one, you'd need to support them all.

dominic_u
3 Aug 2013, 4:50 AM
Why it was behaving correctly on firefox?

evant
4 Aug 2013, 1:43 AM
Because in Firefox it's not rendered to the DOM, it's added as a toolbar to the actual browser interface, not inserted into the page dynamically.

dominic_u
4 Aug 2013, 6:33 AM
I've inspected the DOM and found out that you're right. :(
Even your documentation has an issue to that.