PDA

View Full Version : Ext.Require and variable



Tchinkatchuk
5 Aug 2013, 6:52 AM
Hi all,

I use code like this


Ext.define('QuablePIM.view.article.Grid',
{
requires :
[
Ext.Loader.config.application + '.store.Articles',
'QuableExtends.grid.Panel'
],


cause my file could be used by multiple application.
It works weel except build could not parse the file.
Is there a way to do it ? I could replace the variable by the value but my code will be worst or duplicated.

Thx for any advices.

slemmon
7 Aug 2013, 11:46 AM
While there's not a way to do evaluative requirements at build time with Sencha Cmd today there is a request internally to add that functionality to a future version. For now you'll need to hardcode the required classnames.