PDA

View Full Version : Cannot set background of chart to image



Shamcam
13 Aug 2013, 8:51 AM
Let me start by apologizing if this is a simple problem or it has been posted before. I've been googling/searching and I can't seem to find any kind of solution.

I'm loving Sencha Architect so far, but when I try to set the background of one of my charts, it (nearly) always gives me a black chart. I say "nearly" because if I try something as simple as just to put "green" as the background config setting, it seems to work.

However, if I try to use the code posted in the API reference pages (such as the gradient code), I get a black background on my chart. If I look at the code for it, there is an error next to where it sets the config that reads: "Invalid value: converting to string." It actually even does this if I were to just write "green" in the background config box.

Ultimately, I'd like to be able to use an image as my background.

From my googling and reading through these forums, I would guess my problem would lie within the CSS styling? However, if that is the case, how can I fix that within Architect?

If there is any more information I can provide to help, please let me know!


EDIT:
I figured out what I was doing wrong. I'm extremely sorry for posting this! Could it get deleted??

My problem wasn't within my CSS styling, it was that I was rewriting the class definition within the config definition. I'm an !!

jminnick
13 Aug 2013, 11:14 AM
We'll not delete this. It could potentially help someone else making the same mistake. Thanks for the post.