PDA

View Full Version : Problem with Qtip...



psm1963
6 Oct 2013, 6:16 AM
I am calling InitQtip in OnReady...it used to work but with later browsers the qtip is not appearing...the code is below...perhaps its some small spelling/character mistake...anybody can help would be appreciated...

print "<td align='center' width='5%' ";
print "style='font-size: 10px; ";
#if($favored_status_indicator_count{$a[$j]} == 4) { print "background-color: #c0ffc0;"; }
#elsif($favored_status_indicator_count{$a[$j]} == 3) { print "background-color: #d0f0c0;"; }
#elsif($favored_status_indicator_count{$a[$j]} == 2) { print "background-color: #e0e0c0;"; }
#elsif($favored_status_indicator_count{$a[$j]} == 1) { print "background-color: #f0d0c0;"; }
#elsif($favored_status_indicator_count{$a[$j]} == 0) { print "background-color: #ffc0c0;"; }
#print "' >";
print "' class='favored-status-" . $favored_status_indicator_count{$a[$j]} . "'";
print ">";
print "<div ext:qtip='" . $descriptions{$a[$j]} . "'";
print "&lt;table border=&quot;0&quot;>";
print "&lt;tr>&lt;td>";
print "&nbsp;&lt;td>";
print "BP: ";
print "&lt;/td>&lt;td>";
print ($bullish_percents{$a[$j]});
print "&lt;/td>&lt\/tr>";

israelroldan
14 Oct 2013, 12:54 PM
Seems to me that you're not closing the opening <div> tag. Try changing this line:

print "<div ext:qtip='" . $descriptions{$a[$j]} . "'";
to this one:

print "<div ext:qtip='" . $descriptions{$a[$j]} . "'>";

psm1963
14 Oct 2013, 2:06 PM
Thanks for the reply but I added that on next line...this is what is printed in firebug on this line...maybe more clues to solving...
<div qtip="Health Care Equipmen<table border="0"><tr><td> <td>BP: </td><td>63.7931</td></tr><tr><td><img src="../gifs/red_led.png" /></td><td>PT: </td><td>63.2184</td></tr><tr><td><img src="../gifs/red_led.png" /></td><td>RS: </td><td>764.063</td></tr><tr><td><img src="../gifs/red_led.png" /></td><td>RSP: </td><td>52.8736</td></tr><tr><td><img src="../gifs/red_led.png" /></td><td>RSX: </td><td>44.2529</td></tr></table>">

israelroldan
14 Oct 2013, 2:11 PM
Hmmm that's strange, have you tried printing the value of $descriptions{$a[$j]} as a comment? I'm thinking of something like this:

print "<!-- " . $descriptions{$a[$j]} . " -->";

psm1963
14 Oct 2013, 3:03 PM
Thanks for the tip. I tried it but still issue with tooltip in Firefox or Chrome. Works in IE...This is the code that works in IE...
The following works in IE but not in
print "<div ext:qtip='" . $descriptions{$a[$j]};
print "<table border=&quot;0&quot;>";
print "&lt;tr>&lt;td>";
print "&nbsp;&lt;td>";
print "BP: ";
print "&lt;/td>&lt;td>";
print ($bullish_percents{$a[$j]});
print "&lt;/td>&lt\/tr>";
print "&lt;tr>&lt;td>";
print ($is_percent_above_support_in_xes{$a[$j]} ? "&lt;img src=&quot;../gifs/green_led.png&quot; />" : "&lt;img src=&quot;../gifs/red_led.png&quot; />");
print "&lt;/td>&lt;td>";
print "PT: ";
print "&lt;/td>&lt;td>";
print ($pt{$a[$j]});
print "&lt;/td>&lt\/tr>";
print "&lt;tr>&lt;td>";
print ($is_relative_strength_in_xes{$a[$j]} ? "&lt;img src=&quot;../gifs/green_led.png&quot; />" : "&lt;img src=&quot;../gifs/red_led.png&quot; />");
print "&lt;/td>&lt;td>";
print "RS: ";
print "&lt;/td>&lt;td>";
print ($rs{$a[$j]});
print "&lt;/td>&lt\/tr>";
print "&lt;tr>&lt;td>";
print ($is_percent_relative_strength_in_buy_in_xes{$a[$j]} ? "&lt;img src=&quot;../gifs/green_led.png&quot; />" : "&lt;img src=&quot;../gifs/red_led.png&quot; />");
print "&lt;/td>&lt;td>";
print "RSP: ";
print "&lt;/td>&lt;td>";
print ($rsp{$a[$j]});
print "&lt;/td>&lt\/tr>";
print "&lt;tr>&lt;td>";
print ($is_percent_relative_strength_in_x_in_buys{$a[$j]} ? "&lt;img src=&quot;../gifs/green_led.png&quot; />" : "&lt;img src=&quot;../gifs/red_led.png&quot; />");
print "&lt;/td>&lt;td>";
print "RSX: ";
print "&lt;/td>&lt;td>";
print ($rsx{$a[$j]});
print "&lt;/td>&lt\/tr>";
?
print "&lt;/table>";
print "'>";

psm1963
14 Oct 2013, 3:54 PM
Fixed it it was my bad...was changing wrong file...sorry...anyway you need ext:qtip for Firefox and Chrome...IE will work with just qtip