PDA

View Full Version : Combobox Textfield is lost!



BigBen
15 Oct 2013, 3:53 AM
I have a TabPanel with 3 tabs. The second tab contains a combobox. When I select the tab the combo is shown correctly. When I select the third tab and go back to the second tab the combo lost her textfield! Only the arrow for selection is available. But I can still select values. It looks like this:

First every thin is allright! I can select and it shows the value
46335

When I switch the Tabs and go back, the textfield is lost...

46337

But I still can select - but no text is shown.
46336

If I switch between tab 1 and 2 it won’t happen!

It seems to me that it is a rendering problem?

It only happens at IE8 with documentmode in IE7 AND only when I catch the data from a server. It is not happening if I use my localhost (Server: Tomcat 7.40, local 7.39).
It won’t happen in Firefox, Chrome and IE10.

Any idea what is this about? Thx a lot!

Gary Schlosberg
18 Oct 2013, 6:06 AM
That is very strange indeed. I wasn't able to find any reports of similar behavior. Could there be some kind of conflict with IDs? Any chance you could post a test case which reproduces this issue? You can use Sencha Fiddle (https://fiddle.sencha.com/#home) with your forum credentials to create one.

BigBen
18 Oct 2013, 7:12 AM
No, theres no ID conflict! It doesn't happen if I first select the 3rd tab, an denn go back to the 1st... Thats the workaround for me at the moment.
If I've find some time I'll try to do an test case but I not sure that I can reproduce it in a smaller szenario...

BigBen
21 Oct 2013, 1:50 AM
I can't reproduce it i a smaller environment. I looks like it happens because of some side-effects of my application. Does anybody has an idea what can cause such a strange behavior???