PDA

View Full Version : chrome.extension is not available



qlc
17 Oct 2013, 5:19 PM
Since upgrading to Chrome 29.0.1547 I'm getting these error from ExtJS 4.2.1 as soon as the app launches:



chrome.extension is not available: 'extension' is not allowed for specified context type content script, extension page, web page, etc.). [VM] binding (25):427
Binding.generate [VM] binding (25):427
(anonymous function) [VM] extension (24):114
(anonymous function) content.js:1
Uncaught TypeError: Cannot call method 'connect' of undefined content.js:1


What can I do to resolve this?

As evant stated, this is unrelated to extjs. Unfortunately, I upgraded to Kubuntu 13.10 and it broke a lot of things. If you have this same problem, uninstall chrome and install it using the instructions for "Google Chrome Stable" found here. <a href="http://linuxg.net/how-to-install-the-latest-stabletesting-version-of-chrome-on-ubuntu-and-linux-mint/" target="_blank" rel="nofollow">http://linuxg.net/how-to-install-the-latest-stabletesting-version-of-chrome-on-ubuntu-and-linux-mint/</a>

evant
17 Oct 2013, 5:27 PM
Looks totally Ext unrelated, see: https://code.google.com/p/chromium/issues/detail?id=270060

qlc
17 Oct 2013, 7:29 PM
As evant stated, this is unrelated to extjs. Unfortunately, I upgraded to Kubuntu 13.10 and it broke a lot of things. If you have this same problem, uninstall chrome and install it using the instructions for "Google Chrome Stable" found here. http://linuxg.net/how-to-install-the-latest-stabletesting-version-of-chrome-on-ubuntu-and-linux-mint/