PDA

View Full Version : Drag and Drop error: can not call method isDescendantOf of undefined



blomasky
19 Oct 2013, 9:55 AM
I know, without the code, not easy to see what is happening, but I have 3 tables in a security system, Users, Rights, UserRights. When I select a new user, it will read the userRights and the rights table. After I drag an item FROM the userRights to the Rights table, then select a new user, I get this error when I am reading the rights table.

Commenting out all of the code, so nothing is being done on the drag / drop I still get that error but only after I drop a record on that table.


Bruce

Gary Schlosberg
19 Oct 2013, 10:10 AM
In what version are you seeing this issue? Which browsers? Test cases certainly help, as you mentioned. Could it be this issue?
http://www.sencha.com/forum/showthread.php?267022

blomasky
19 Oct 2013, 10:22 AM
OS X 4.2.2 (tried with last nightly build of 4.2.3 and get same error), Chrome. And YES, the grid with the error has a CELL selection model (since it is editable). So, this is a known issue and being worked on?

bruce