PDA

View Full Version : Warnings



LesJ
13 Nov 2013, 11:25 AM
Why am I seeing these warnings in the console?

OS X
Ext JS 4.2.2

body.scrollLeft is deprecated in strict mode. Please use 'documentElement.scrollLeft' if in strict mode and 'body.scrollLeft' only if in quirks mode. ext-dev.js:28336

body.scrollTop is deprecated in strict mode. Please use 'documentElement.scrollTop' if in strict mode and 'body.scrollTop' only if in quirks mode. ext-dev.js:28337

LesJ
18 Nov 2013, 7:49 AM
You can see the same warnings when accessing Sencha doc on a Mac. Is Ext JS using deprecated methods?

46897

Gary Schlosberg
20 Nov 2013, 5:10 PM
I am not seeing those console warnings when I access the docs. Are you using this URL?
http://docs.sencha.com/extjs/4.2.2/#

LesJ
20 Nov 2013, 5:15 PM
46937Yes, I'm seeing these warnings when following this link.Mac, Chrome 32 Beta

LesJ
21 Nov 2013, 6:53 AM
I see the same warnings using Windows 7 and Chrome Version 32.0.1700.19 beta-m Aura

46939

Decoy Deluxe
21 Jan 2014, 5:54 AM
Ditto, new chrome console is quite annoying

RoyalSens
29 Jan 2014, 3:12 AM
Will there be a fix for this? Currently I patched ExtJS myself on some places, but I'm hesitant to edit all occurrences. Because I don't know if ExtJS itself relies on some deprecated stuff.