PDA

View Full Version : ExtJS is not working properly in IE



samarth
14 Nov 2013, 9:49 PM
Hi,
I am using ExtJS 3.4. My application is working fine in mozilla firefox and google chrome browser. But it is not working well in Internet explorer browser. I am using IE version 10. Any plugin or adds on is required to work well in IE?

Thanks in advance.

stephen.aaes
14 Nov 2013, 11:45 PM
"I am using ExtJS 3.4"

Which version of ExtJs 3.4 are you using? IE10 support was not added until version 3.4.1.1. You should not need any extensions or plugins.

samarth
14 Nov 2013, 11:47 PM
Hi stephen.aaes,
I am using ext-3.4.0 this version.


Which version of ExtJs 3.4 are you using? IE10 support was not added until version 3.4.1.1. You should not need any extensions or plugins.

stephen.aaes
14 Nov 2013, 11:51 PM
Then you'll have to either add the proper meta tag to you application - or upgrade to ExtJs 3.4.1.1 to get it working properly in IE10:


<!DOCTYPE html>
<html>
<head>
<meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7;">
</head>
<body>
</body>
</html>

Meta tag example was taken from this thread: http://www.sencha.com/forum/showthread.php?275609-need-to-avert-IE11-crisis-requires-ExtJS-v3-update

samarth
2 Dec 2013, 9:36 PM
Hi stephen.aaes,
It worked me right now thanks for your kind reply.

Then you'll have to either add the proper meta tag to you application - or upgrade to ExtJs 3.4.1.1 to get it working properly in IE10:


<!DOCTYPE html>
<html>
<head>
<meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7;">
</head>
<body>
</body>
</html>

Meta tag example was taken from this thread: http://www.sencha.com/forum/showthread.php?275609-need-to-avert-IE11-crisis-requires-ExtJS-v3-update