PDA

View Full Version : EXT Js 4.2.2.1144 lib not supporting adding rowEditor dynamically to grid



guruprasad mangalore
25 Nov 2013, 4:47 AM
We were using ext-4.2.1.883 and dynamically adding rowEditor instance to grid using method addplugin.
It was working fine but when we migrated from ext-4.2.1.883 to 4.2.2.1144, this addplugin method not adding plugin instance to grid dynamically.Making grid not editable.
Debug shows that beforeedit not firing on reowEditing .
below is the code snippet how we used rowEditing


var rowEditing = Ext.create('Ext.grid.plugin.RowEditing', {
clicksToMoveEditor: 1,
autoCancel: false,
errorSummary: false,
pluginId: 'rowEditing'
})

grid.addPlugin(rowEditing);

grid.on('beforeedit', function (editor, context, eOpts) {
//implimentation
});

Please let me know if there is any changes related to adding roweditor dynamically in 4.2.2.1144


Regards
Guruprasad

scottmartin
26 Nov 2013, 10:41 AM
Known bug:

http://www.sencha.com/forum/showthread.php?275875