PDA

View Full Version : Error when access Ext.ux mulitselect.js



bolehjadi
10 Dec 2013, 1:48 AM
Hai all,, Iam new in the sencha especially for sencha xtjs,, I have a problem, in my application I want to use Multiselect and itemselector compone.. I want to make look like this link http://dev.sencha.com/deploy/ext-4.0.7-gpl/examples/multiselect/multiselect-demo.html.

but I have big problem,, when I tried to access Ext.ux that contained multiselect.js and itemselector.js .. like below in my conroller :

Ext.Loader.setConfig({enabled: true});
Ext.Loader.setPath('Ext.ux', 'app/ux');
Ext.require([
'Ext.form.Panel',
'Ext.ux.form.MultiSelect',
'Ext.ux.form.ItemSelector'
]);

I got error like this :Uncaught TypeError: Cannot read property 'autoCreated' of null. when I run my project..

47167

Plese somebody help me,, I have tried for 2 days and still error..

Kevin Jackson
13 Dec 2013, 1:10 PM
The js for that example that you provided (if that is what you are trying to accomplish) is not minified, so you should be able to see how it was constructed. Have you tried that? If not, could you provide a code example https://fiddle.sencha.com/#home