PDA

View Full Version : [FIXED] Grid load mask does not work with locking in version 4.2.2



avcmc
17 Dec 2013, 11:50 PM
In version 4.2.2, if we use locking in grid then load mask stops working, and thus when the grid store loads then no masking message gets displayed to the user.

As soon as locking is removed then load mask starts appearing again. The behavior is same across all the browsers (IE8+, Chrome18+, FF5+).

This issue can be simulated from any of the online example by making locked:true for a column:

http://docs.sencha.com/extjs/4.2.2/#!/example/build/KitchenSink/ext-theme-neptune/#array-grid
(http://docs.sencha.com/extjs/4.2.2/#!/example/build/KitchenSink/ext-theme-neptune/#array-grid)
Could this please be looked into and some work around suggested for the time being, as its getting to be a turn-off for the users as they don't realize whether the grid is loading or not?

Thanks.

israelroldan
19 Dec 2013, 8:37 AM
Thanks for the report! I have opened a bug in our bug tracker.

timswink
13 May 2014, 4:13 AM
Is there some news about a possible workaround/override?

I'm using Architect 2 and want to upgrade my project from 4.2.1. to 4.2.2. But this bug is preventing me to do so. A possible override would be great.

Stokes
15 Jul 2014, 5:00 PM
I ran into this problem too, and looked at the Ext.grid.locking.Lockable mixin to try to see what was going wrong. It seems like it might be a bug, but injectLockable() refers to me.loadMask at line 343 of Lockable.js.

So I tried just using loadMask:true on my grid itself, even though that's not a documented config/property of the Ext.grid.Panel class and it worked for me.

So to be clear: Not in viewConfig: or lockedViewConfig: or anything like that, but as a config to the grid panel itself. When I put loadMask:true there the load mask started showing up for me when locked columns are used.