PDA

View Full Version : Msg CSS



INeedADip
1 Mar 2007, 12:20 PM
http://yui-ext.com/deploy/ext-1.0-alpha1/examples/menu/menus.html

CSS Questin/Bug.

I love the small 'msg' that pops up when you click on the different menu items/buttons.

But the CSS is a little off in the bottom left hand corner (in IE). Has anyone been able to fix that?
I've been messing around with CSS with no luck. I'm sure there are a couple CSS experts out there..has anyone found a fix?

INeedADip
1 Mar 2007, 1:35 PM
Can anyone even see this little quirk or is it just me?

KimH
1 Mar 2007, 1:38 PM
I see it too... IE6 on XP

JeffHowden
1 Mar 2007, 1:41 PM
Please make sure you're looking at the most current version of that particular example:

http://yui-ext.com/deploy/ext-1.0-alpha2/examples/menu/menus.html

INeedADip
1 Mar 2007, 1:44 PM
Good point about looking at Alpha 2...but....

I see the same thing..the message that drops down looks funny (Bottom left corner).

JeffHowden
1 Mar 2007, 1:51 PM
Well, to be fair, that is something constructed purely for the examples. In fact, you'll see it's a msg() method namedspaced to Ext.example and only defined in examples.js. I suspect what you're seeing is something to do with a PNG in IE6. Personally, since it's not part of the actual framework, I wouldn't worry about it.

INeedADip
1 Mar 2007, 1:56 PM
I was ready for that response. I just liked the box and was trying to use it. I understand that it's not a part of the library...

I know there are a lot of smart people in the forms and I was just hoping some could have taken a look and given me a quick fix.

No problem though...back to the drawing board I guess.

malnart
1 Mar 2007, 2:17 PM
I fix it by overwriting the gifs in this folder:

ext-1.0-alpha2\resources\images\default\box

with the same gif's from an earlier release. I use the very first version of ext-1.0-alpha1. Hopefully you still have a copy of it lying around somewhere.

INeedADip
1 Mar 2007, 2:24 PM
I actually don't.
Could you do me a huge favor and email it to me at: ineedadip AT gmail.com

I'd appreciate it...otherwise I can start editing the .gif that I've got and try to figure it out.

INeedADip
1 Mar 2007, 2:48 PM
I appreciate the files that you sent...but the difference in the .gif's was the fact that the corners were not transparent..so that would fix the problem on a white background.

My background is actually gray so it didn't help.

I did figure out a horrible hack though:

I added:

padding-bottom: 1px;
background-color: #eee;

to .x-box-ml

Now the problem is a little less obvious. There is a 1px line on the bottom right side of the box, but you really have to look for it in IE.

Hopefully that helps someone else out.