PDA

View Full Version : Seeing the following warning on Chromes Javascript Console



blomasky
29 Jan 2014, 11:47 AM
This just started, wonder if there is a way to suppress this:

body.scrollLeft is deprecated in strict mode. Please use 'documentElement.scrollLeft' if in strict mode and 'body.scrollLeft' only if in quirks mode. ext-dev.js:28659 (http://localhost:8500/alc/ext/ext-dev.js)
body.scrollTop is deprecated in strict mode. Please use 'documentElement.scrollTop' if in strict mode and 'body.scrollTop' only if in quirks mode.



thanks

Bruce

Malte123
29 Jan 2014, 3:55 PM
I think it happens only if you use ext-dev.js

later if you go for production you will use ext.js or ext-all.js ...

so change your index.html to load those instead of ext-dev.js and see if this bring away the messages about deprecated way to work with scrolling methods within ext-dev.js ...

blomasky
30 Jan 2014, 12:56 PM
I changed it to ALL, and I still get the warnings... Its not a serious problem, but wonder why this started a week or 2 ago.

skirtle
30 Jan 2014, 1:01 PM
These appear to be Chrome warning you about using deprecated APIs. I'd guess the warnings started after a Chrome update.