PDA

View Full Version : Using GXT 3.1.0 and GXT 2.2.5 together



piskantali
11 Mar 2014, 6:57 AM
Hello everyone. From this article (http://docs.sencha.com/gxt/3.1.0-beta/getting_started/migration/Migration2and3.html) I know, that there is a way to use GXT 3.0 alongside other older versions, but I'm interested, if there will be any problems in using newly developed GXT 3.1.0 beta with this particular older version - GXT 2.2.5 ?

Colin Alworth
15 Mar 2014, 12:32 PM
GWT 2.6 had some breaking changes that prevents a GXT 3 release from being compatible both with it and with earlier releases. This means that GXT 3.0 will remain compatible with GWT 2.4-2.5.1, but GXT 3.1 will only be compatible with GWT 2.6+.

GXT 2.2.5 is a very old release, since then 2.2.6, 2.3.0, and 2.3.1 have been shipped (not to mention 3.0.0-3.0.6 and 3.1.0-beta). We will be releasing a GXT 2.3 release that adds compatibility with GWT 2.6, but are still testing this before we ship it. I don't presently expect that we will ship an update to 2.2.5 that adds GWT 2.6 compatibility, any more than we will release a 2.2.4 update.

walkerr
8 Apr 2014, 1:30 AM
Any more news on a 2.3.x release that will support GWT 2.6?

oucem
9 May 2014, 12:16 AM
Hi in case to migrate my modules from GXT 2.2.4 GWT 2.5.1 to GXT 2.31 and GWT 2.6.0(or 2.6.1-rc1) ; i got this error:
[ERROR] Errors in 'jar:file:/C:/Users/XXX/.m2/repository/com/extjs/gxt/2.3.1-gwt22/gxt-2.3.1-gwt22.jar!/com/extjs/gxt/ui/client/widget/form/HtmlEditor.java'[INFO] [ERROR] Line 548: Type mismatch: cannot convert from com.google.gwt.dom.client.Element to com.google.gwt.user.client.Element
[INFO] [ERROR] Errors in 'jar:file:/C:/Users/XXX/.m2/repository/com/extjs/gxt/2.3.1-gwt22/gxt-2.3.1-gwt22.jar!/com/extjs/gxt/ui/client/widget/treepanel/TreePanel.java'[INFO] [ERROR] Line 1634: The constructor El(Element) is undefined.

:sAny help is appreciated