PDA

View Full Version : Simple Task Bug



AlanBee
25 Mar 2014, 5:49 AM
Hi,

I have been trying to use the Simple Task and discovered an issue/bug.

When I'm adding a new task it is working well. The issue is when I'm trying to add a new folder.
The folder is being added, but when I refresh the page the folder disappears. It happens only with the New List and Folders.

I have changed it to false at the SimpleTaskSettings.js file.

Here is the link to the Simple Task on my server: http://www.alphawebst.com/filez/ext-4.2.1.883/examples/simple-tasks/index.html

Also attached a video. Click Here (ftp://www.alphawebst.com/filez/ext-4.2.1.883/examples/simple-tasks/index.html)

What can I do to fix it?

Please help me.

Thank you,

Gary Schlosberg
25 Mar 2014, 7:46 AM
Thanks for the report. Guessing this is ExtJS 4.2.1? Can you please post a Fiddle which reproduces the problem?
https://fiddle.sencha.com/#home

AlanBee
25 Mar 2014, 11:16 PM
I don't really know what to do with what you sent me, but you can see the issue from the link that I sent in my first post. The version is ExtJS 4.2.1.

This is what I have done:

Downloaded the zip file from your site.
Uploaded it to my server.
Went into this path: ext-4.2.1.883/examples/simple-tasks/SimpleTaskSettings.js and changed it to false so the php backend will be used (this is what the instructions ordered to do if you open the SimpleTaskSettings.js file).
The simple task is working, but not saving the folders that I'm creating.
I didn't change anything else and it should work as the "All" folder is working well. The new folders are the issue.


Please check this video:
www.alphawebst.com/filez/2014-03-25_1242.swf


Please check. I believe that this is a small bug, but I don't know how to fix it.


Thank you for your help.


Alan

Gary Schlosberg
28 Mar 2014, 6:25 AM
So you have the PHP script configured so it reads from and writes to your database?

AlanBee
29 Mar 2014, 11:18 PM
Yes it is reads from and writes to my database.


As I have explained before, if I'm adding something using the "All" folder tab, it is working well and gets displayed. The issue is when I'm creating a new folder. The folder disappears after I refresh the page. I have checked and the folders and everything that I'm creating is still in the database, but will not show if it is not created under the "All" folder tab. You can try it yourself here:


http://www.alphawebst.com/filez/ext-4.2.1.883/examples/simple-tasks/index.html


I have uploaded it so you can test it and see. Please use it any way you want to see the issue.


Thank you very much for your help.


Alan