PDA

View Full Version : How hard can it be an "urgent" migration from 3.0.0 to 3.4.x?



sjuan76
27 Mar 2014, 12:23 AM
Hi!

Recently (3 months ago) I have started this job taking over maintenance of an application that uses Ext 3.0.0.

I have my hands full with the app bugs and I wanted to wait to have it more stabilized to upgrade extJs (to begin with, to 3.4.x), but I found myself wanting to use some components that are not part of 3.0.0 (like http://dev.sencha.com/deploy/ext-3.4.0/examples/multiselect/multiselect-demo.html).

How difficult is supposed to be if I just swap the libraries in my application with the 3.4.0 version? Will it be likely to break the current JS?

Thanks in advance
Sergio

Gary Schlosberg
27 Mar 2014, 5:21 AM
I don't think there's a general answer here. It is preferred to upgrade more frequently, but you may have a smooth upgrade depending on what your code looks like. Can you test your code against 3.4.x to see how it performs?

wm003
27 Mar 2014, 11:59 PM
It basically shouldn't trigger much problems. Are you using many ux? Then try to get the lates versions from them aswell.