PDA

View Full Version : Documentation for "itemselector" component?



sjuan76
27 Mar 2014, 12:56 AM
Hi

Looking at the ExtJs 3.4 examples (http://dev.sencha.com/deploy/ext-3.4.0/examples/), I found a "Multiselector" and "ItemSelector" example(http://dev.sencha.com/deploy/ext-3.4.0/examples/multiselect/multiselect-demo.html), but looking at the API docs linked in the same page(http://docs.sencha.com/extjs/3.4.0/) I fail to see any component that seems related.

Also, in the "components" page, I find no "xtype" valued "itemselector". Yet, it is used in the examples (and also in some posts in this forum).

I am missing something? Where in the docs may I find the "ItemSelector" component info (note: I find some attributes with such name, but it does not seem related)

Thanks in advance

Gary Schlosberg
27 Mar 2014, 6:23 AM
I couldn't find documentation for that, but I was able to find it in an earlier version:
3.3.3/examples/docs/output/Ext.ux.form.ItemSelector.html

I believe user extensions (having been created by users) were created to implement functionality not included in the core framework. Docs would be provided by the authors. In Ext4, many user extensions were incorporated into the framework and one finds the ux namespace in the docs.

Do you have specific questions about usage?

sjuan76
28 Mar 2014, 1:05 AM
Hi Gary, thanks for your answer.

Since it was in the examples page I assumed that it was part of the ExtJs "kernel" and that I was my fault if I did not find the docs.

Right now I am just doing a review (windows shopping?) of what I have available in ExtJs so I have no specific questions about the components (well, maybe it is worth knowing which versions of ExtJs they do support, since for now I am stuck with 3.0.0).

A question that comes to my mind is: where can I look for more ux components? Community -> Sencha Market seems the place to go, but I cannot find "itemselector" there. Should I search inside the "ExtJS 3 : User extensions and plugins forum" instead?

Gary Schlosberg
28 Mar 2014, 6:30 AM
Any chance you can upgrade to 4.2.1? In Ext 4, many popular user extensions have been incorporated into the framework. For Ext 3, the User Extensions and Plugins forum is good place to look.
http://www.sencha.com/forum/forumdisplay.php?42-Ext-3.x-User-Extensions-and-Plugins