PDA

View Full Version : [FIXED] trying out viewModel



christophe.geiser
4 Apr 2014, 6:18 AM
Hi,
Trying the promising new viewModel class here, and cannot find out what I am missing to make model changes automatically being applied to the view.

In the ticket-app example, I just added a displayfield to the Ticket form (attached picture) with following config:


{
xtype: 'displayfield',
fieldLabel : 'display',
bind : '{theTicket.title}',
publishes: ['value']
}


What I am expecting to see is this display field to be updated when the title is edited (same with the title of the form - which is also bound to the same viewModel data element). But the editing does not seem to get notified.
Any hint ?
Cheers,
C.

evant
4 Apr 2014, 6:54 AM
It's a known issue, currently the view models have dependencies on sessions to manage record interactions. We need to remove these so viewmodels can bind directly to records without needing a middle man.

christophe.geiser
4 Apr 2014, 7:06 AM
ok, thanks,
C.

jorgemanrubia
29 Apr 2014, 9:02 AM
I am also experiencing this issue. I would like to know: is removing that dependency a goal before releasing the official 5.0? Or is it something you intend to do later?

evant
29 Apr 2014, 3:41 PM
It will happen before 5.0.0.

jorgemanrubia
2 Jun 2014, 2:43 PM
Hi,I am still experiencing this issue after updating to official 5.0 version.Pushing this bug up in the forum. I think it's an important one.Regards

evant
2 Jun 2014, 2:50 PM
The issue has already been resolved. If you're still seeing a problem, please post a test case.