PDA

View Full Version : Unable to upgrade to Sencha Cmd 5.0.0.116



pbienick
8 Apr 2014, 6:21 AM
Your recent blog post about Ext JS 5 states "We’ve also made smooth upgrades from Ext JS 4 a priority." Let's see if you really meant that, because I've never been able to upgrade any of my Ext JS apps without having to start over from scratch with "sencha generate app".

So far, I can't even upgrade Sencha Cmd 4.0.2.67 to 5.0.0.116, let alone upgrade Ext JS itself. This is what I get when I run sencha app upgrade -nof.


Sencha Cmd v5.0.0.116
[INF] upgrading application
[INF] Upgrading to sdk at /Users/paulb/Projects/BlueSage/HIP/web-app/ext
[INF] Updating application and workspace from Ext JS 4.2.2.1144 / Cmd 4.0.2.67
[ERR]
[ERR] BUILD FAILED
[ERR] com.sencha.command.environment.IncompatibleException: Sencha Cmd version (5.0.0.116) is incompatible with required version (3.1.0.206-3.1.3.372)
[ERR]
[ERR] Total time: 2 seconds
[ERR] com.sencha.command.environment.IncompatibleException: Sencha Cmd version (5.0.0.116) is incompatible with required version (3.1.0.206-3.1.3.372)
[ERR]
The application was last modified by an older version of Sencha Cmd (4.0.2.67)
the current is 5.0.0.116.
Please run "sencha app upgrade" to update to 5.0.0.116.

dongryphon
9 Apr 2014, 10:45 PM
You'll need to remove the "-nof" flag - we have marked Cmd 5 as incompatible with older frameworks so that it will delegate to v4 when run on older (production) apps. Check out http://docs-origin.sencha.com/extjs/5.0.0/whats_new/5.0/cmd_upgrade_guide.html for the steps.

dongryphon
9 Apr 2014, 10:46 PM
We will remove the incompatible marker when Cmd 5 is GA.

pbienick
10 Apr 2014, 7:34 AM
Ok - thanks, Don. I've found a bunch of other issues that I'll have to start separate threads for when I have the time.